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CHAPTER 1
Introduction
This chapter describes what you will find in this book. System requirements and 
installation instructions for ToolBook are included.
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About this book
This book covers the basic aspects of creating online content with ToolBook: start with 
a template, add your text and graphics, and then use the Publish to Web menu 
command to automatically build web pages. 

For more detailed information about the features in ToolBook Instructor™ or ToolBook 
Assistant™ consult the online User Guide that ships with ToolBook; this PDF file is 
available from the Help menu after you start ToolBook.

System requirements
Your computer must meet the minimum requirements described below to run 
ToolBook.
Operating systems

Windows 2000 SP4, Windows XP SP2, or Windows Vista 

Hardware requirements
Pentium® 233 processor minimum (Pentium® III 1.2 GHz or higher 
recommended) 

128 megabytes (MB) of random access memory (RAM) for authoring (256 MB or 
more recommended) 

250 MB or more free hard disk space (up to 450 MB for all optional components) 

CD-ROM or DVD drive 

Graphics card capable of 800 x 600 pixel display with 16-bit color or greater (1024 
x 768 recommended) 
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Installing ToolBook
The Setup program for ToolBook will start automatically when you put the ToolBook 
program disc into your CD-ROM drive. Follow the prompts shown on the screen to 
install ToolBook. 

You may choose to install ToolBook manually as described below.

To install ToolBook manually:

1. Insert the ToolBook program disc into your CD-ROM drive.

2. Click the Start button and choose Run.

3. In the Run dialog box, type the location from which you are installing 
ToolBook, plus the word setup. For example, enter d:\setup

4. Click OK and then follow the instructions on the screen.
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CHAPTER 2
Creating a new book 
for content
Content that you create in ToolBook is stored in a book file. A book is composed of 
pages with objects such as buttons. 

You can create a new book using a wizard that gathers input from you and prepares 
pages with a consistent theme and layout.
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Starting ToolBook
To start ToolBook Instructor: 

• Click the Start button on the taskbar. Point to Programs, ToolBook 9, 
Instructor, and click ToolBook Instructor.

To start ToolBook Assistant: 

• Click the Start button on the taskbar. Point to Programs, ToolBook 9, 
Assistant, and click ToolBook Assistant.
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Beginning a new book
A book is a collection of pages stored as a single ToolBook file. You can start a new 
book from the Startup screen that displays as soon as you open ToolBook.

  Figure 1  The Startup dialog box

To create a new book:
1. Open ToolBook from the Start button on the Windows taskbar.
2. Click the Book Wizard tab.
3. Select the Book Wizard icon.
4. Click OK.
5. Follow the instructions on the screen.
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Another way to create a new book is to choose a template. After you start ToolBook, 
click the Templates tab in the Startup screen shown in Figure 1.

Changing the text in the title bar
Every book has a title that displays in the title bar. You can edit the default title 
assigned to a book.

  Figure 2  Text entered for title displays at the top of the window

To change the title of a book:
1. From the Object menu choose Properties for Book.
2. Click the Summary tab.
3. Enter text in the Book title field.
4. Close the dialog box to save your title.



CHAPTER 3
Working with pages

 

You will find out how to move between the authoring workspace and the view of 
content that learners see, called Reader level, in this chapter. Important authoring 
tasks such as adding new pages, navigating between pages, and switching to the 
background of a page are also discussed.



11 Working with pages
Switching views
When you first open ToolBook, you see the Author level workspace. Author level is 
where you build content by entering text, adding graphics, and more. The catalog is 
available at Author level along with other development tools such as the shortcut 
menus, toolbar, Book Explorer, and ToolBook Coach. 

You can switch to Reader level to see how pages will look to the end users. 

To move from Author level to Reader level:
1. From the View menu select Reader.
2. Press F3 to return to Author level, or click the View menu and select Author.

You can test links and other functionality at Reader level. 

Several changes take place when you switch from Author level to Reader level. At 
Reader level:

• Menus do not contain the development-related commands, and shortcut 
menus are disabled. 

• The authoring tools are not available, such as the toolbar and catalog.  

Navigating between pages
You can move from one page to another in a book using the:

• commands on the Go menu.

• Previous Page or Next Page buttons on the status bar (in ToolBook Instructor) 
or the toolbar (in ToolBook Assistant).

• arrow keys on the keyboard; press while the ALT key is held down.  

The Book Explorer provides a visual way to locate and navigate to pages. For more 
information, see page 27.
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You can also navigate by entering a page name or number in the Go To dialog box, 
available from the Edit menu.

Adding new pages
If you have started a book using a template or the Book Wizard, the fastest way to add 
new pages is to select one from the catalog. A new page from the catalog will match 
the style of your book.

To add a new page in a matching style:
1. If the catalog is not open, from the View menu choose Catalog. 
2. Click the Pages category.
3. Point to any small page image to view a description of the page.
4. Drag a page from the catalog to your book.

The new page will match the existing look of your book.

If you want a page that has nothing on it, you can add a blank page by opening the 
Insert menu and choosing New Page.

Deleting pages
Once a page is deleted, it cannot be recovered.

To delete a page:
1. From the Edit menu choose Select Page.
2. Press the Delete key.
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Viewing the page background 
A button or any other object placed on the background will display on all pages that 
share the same background. 

To move to the background of a page:

• From the View menu, select Background.

The background pictured below contains a logo and navigation buttons, which display 
on all pages that use the background.

A background is the foundation for a page. Many pages can share a background. 
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Changing the page size
A page has the same size as its background.

To change the page size:
1. From the Object menu select Properties for Background. 
2. Click the Page tab.
3. Remove the check from the box labeled “Use the book default page size”. 
4. Select a page size. 

If you have multiple backgrounds in a book, keep in mind that a web browser has a set 
window size that will not resize to fit different page sizes. When ToolBook prepares 
web pages from a book, the browser window will be set to the size of the largest 
background in a book
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CHAPTER 4
Using the catalog

 

The catalog contains a variety of objects such as questions and text fields. You can 
browse through the catalog to find objects that you can use. This chapter explains 
how to add catalog objects to your content. Also, you’ll find out how to hide or show  
categories in the catalog and position the catalog window.



17 Using the catalog
Adding objects from the catalog
The catalog contains a collection of objects that you can add to pages. Text fields, 
buttons, and interactive questions are some of the objects you will find in the catalog.

When you click a category button in the catalog, small thumbnail images of objects 
appear below the category button. You can drag one of these thumbnails to a page to 
add the object to your book.

To display the catalog:

• From the View menu select Catalog.

For a description of a catalog object, point to the thumbnail image in the catalog and 
pop-up text will display.
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To add a catalog object to a page:

• Choose an object in the catalog and drag from the catalog to the page. 

As soon as you add a catalog object to a page, the properties dialog box for that 
object will open to allow you to set options.

For information about setting up a catalog object, read the steps shown in 
the ToolBook Coach. Open the Coach from the Help menu. Select an 
object on the page and the Coach displays steps to use it. 

Searching for objects 
You can enter search words to find any catalog objects with a description or name that 
matches your entry.

To search for an object in the catalog:
1. Open the catalog if it is not currently open.
2. Right-click on a category button in the catalog and choose Find Object from 

the shortcut menu.
3. Enter a keyword in the Find Object dialog box.
4. Click the Find button.

Hiding categories
All of the categories available in the catalog may or may not be visible, depending on 
your preference. You can display categories that are not shown by default by selecting 
the categories you want to view.

To change the display of categories in the catalog:
1. Open the catalog if it is not currently open.
2. Right-click on a category in the catalog and choose Customize Catalog from 

the shortcut menu.
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3. Select one or more categories that you want to display and then click OK.

Positioning the catalog window
You can choose the location for the catalog. It can be attached to the left or right side 
of the ToolBook window, or shown as a floating window.

To change the location of the catalog window:
1. In the catalog, right-click on a category button and choose Position from the 

shortcut menu.
2. Select either Docked to Left, Docked to Right, or Floating.



CHAPTER 5
Adding text and 
graphics
You add text to a book by placing text in text fields. This chapter describes how to 
enter and format text, and how to incorporate graphics and media files in a book.
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Entering text
You add text to a page by placing text in a text field. ToolBook provides a wide variety 
of text fields in the catalog. Some examples of text fields are shown below. 

You can drag any text field you want from the catalog to a page.

To type text in a field:

• Double-click a text field and enter text.

When the insertion point displays in a text field to allow you to enter text, you can 
move the insertion point to a different text field by clicking only once.

To paste text into a field:
1. Open the file that contains the text you want and copy the text.
2. In ToolBook, double-click the text field where you will paste the text.
3. From the Edit menu choose Paste Special. 
4. Select Rich Text Format and click OK.

You can also use the standard Windows shortcut keys for copy and paste: CTRL+C 
and CTRL+V. 
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If you copy text from Microsoft Word and paste it into ToolBook, some kinds of 
formatting may not display as expected. WordPad, a program included with Windows, 
has special handling for Microsoft Word's rich-text format (RTF). If you copy text from 
Word into WordPad, and then copy it from WordPad before pasting it in ToolBook, the 
result can be more successful. 

To import text:
1. Double-click the field that will hold the text you import.
2. From the Insert menu choose Text.
3. In the Import Text dialog box, choose an RTF file or a TXT file and click Open.

Formatting text 
Every text field has default text properties such as font color and font size. You can 
format text by applying a format to selected characters or change the paragraph 
formatting for an entire text field. 

To change the formatting for all text in a field:
1. Select a field by clicking it once. 
2. From the Object menu choose Properties for Text Field.
3. Click the Paragraph tab to change the alignment, spacing, or indents of the 

text.
4. Click the Font tab to change the font type, style, or size. 
5. Close the Properties dialog box.

To format selected characters:
1. Select the words you want to format.
2. From the Object menu choose Properties for Text Field.
3. On the Font tab, choose the font style, text color, size, or effects you want.
4. Close the Properties dialog box.
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Turning text into a link 
A link allows the user to jump from one page to another. The page which opens may 
be a different page in a book or a web page on the Internet.

One option is to set up a link that navigates to another page. Another option is to 
create a link that opens a pop-up window to show a different page. 

To create a link to another page:
1. Select the word or characters that will become the link.
2. From the Object menu choose Hyperlink.
3. In the Type of link list, select the kind of link you want to use.
4. Under Link to, select the type of link you want, and click OK.

If you want to change the color or appearance of a link, select it, open the Object 
menu, and choose Properties for Hotword.

Adding graphics and photos
When you paste a graphic on a page or import an image, ToolBook uses an import 
filter to convert the graphic file to a paint object (bitmap) or a picture object (vector 
graphic). During the publish to web process, ToolBook exports all graphics to the 
Internet-compatible file formats of JPEG or GIF. 

If you already have JPEG or GIF files, you can show the original files on a page using 
the Web Graphic placeholder object.

To display a graphic (JPG or GIF) using a placeholder:
1. Open the catalog.
2. Choose the Placeholder Objects category.
3. Locate the Web Graphic placeholder and drag it to a page.
4. Select the file that will display.
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Showing a GIF or JPG in a placeholder object has the advantage of adding a graphic 
to a book as a resource, which is a file that can be used multiple times but is only 
stored once to reduce the file size. Also, showing a graphic in this placeholder retains 
the original file with no changes. 

Be sure to resize and edit a graphic before you import or paste it on a page, 
because you cannot edit the image in ToolBook.

Another way to display a graphic is to import it. ToolBook places a border around an 
imported graphic. You can remove this border by opening the Properties dialog box, 
then click the Draw tab and select None from the Line style list.

To import a graphic:
1. From the Insert menu choose Graphic.
2. Select the source file in the Import Graphic dialog box.

Copying and pasting a graphic in ToolBook is similar to importing a graphic. A border 
displays around a graphic which is pasted on a page. You can remove this border by 
selecting the graphic, opening the Properties dialog box, and changing the line style 
setting to None. 

Playing video, audio, and Flash files
The Universal Media Player is the easiest to use and most versatile of all the media 
player objects available in ToolBook. You simply choose the file to display, and 
ToolBook automatically presents the appropriate player at Reader level. A wide variety 
of file formats are supported. 

To add a Universal Media Player:
1. If the catalog is not currently open, from the View menu choose Catalog.
2. Open the Media Players category, select the Universal Media Player, and 

drag it to your page.
3. When the Properties dialog box opens, select the file to play.
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CHAPTER 6
Working with objects 
and properties
Properties for an object include the color, size, and location of an object on a page. 
You can modify the default property settings to change the appearance and 
sometimes the behavior of an object.

All of the objects on each page are shown in an outline view in the Book Explorer. This 
interactive object browser allows you to rearrange and edit pages, view miniature 
page images, access properties, and more.



27 Working with objects and properties
Using the Book Explorer 
All of the objects on each page of a book are listed in an outline view in the Book 
Explorer. In this interactive browser, you can move objects, view page thumbnail 
images, and navigate to any page you select. 

Selecting an object in the Book Explorer causes it to be selected in the main window 
as well. When you select a page name, the page displays in the main window. 

A small preview image of a page appears next to the Book Explorer if you point to a 
page name with the mouse. 
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You can reorder pages in the Book Explorer to arrange the sequence of pages by 
using drag and drop. Move an object to another page or a different layer on a page by 
dragging the object to a new location in the Book Explorer. 

To open the Book Explorer:

• From the View menu select Book Explorer.

Setting properties 
All objects in ToolBook (such as buttons) have properties that define their look and 
behavior. The properties you can set for a button, for example, include the color, 
caption, size, location, and so on.

You can set properties by selecting an object and opening the Properties dialog box. 
Changes that you make in the Properties dialog box take place immediately.

To display the Properties dialog box:

• Click the Properties button  on the toolbar.

In the Book Explorer, 
to... Do this...

Preview a page Point to a page name using the mouse.
Select an object Click it once, and ToolBook will select the 

object in the main window also. 
Navigate to a page Click the name of a page.
Move a page Drag it up or down in the list of pages. 
Move an object to a 
different layer or page

Select an object, drag it up or down the list, 
and drop it where you want it.

Open the shortcut 
menu for an object

Right-click an object in the Book Explorer.
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The settings in the Properties dialog box apply to the currently selected object. 
Options and tabs available in the Properties dialog box change according to the 
currently selected object.

 Figure 1  The Properties dialog box

Understanding extended properties
Catalog objects often have properties that set sophisticated capabilities in addition to 
the standard properties for an object. These properties are called extended properties. 
A multiple choice question object, for example, has extended properties that define 
the correct answers, incorrect answers, and the score for the question.

You can set extended properties for catalog objects in the Extended Properties dialog 
box. To see whether an object has extended properties, select the object and look at 
the Extended Properties button on the toolbar. This button is available only when you 
select an object with extended properties.

To set extended properties for an object:
1. Select the object.

2. Click the Extended Properties button on the toolbar.
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3. Specify the options you want in the dialog box and click OK.

Many of the objects in the catalog are actually a group of individual objects. If you 
double-click an individual object inside a group, you can access the standard 
properties for the selected object.

Selecting objects
When you select an object, ToolBook displays small handles around the object.

You can select single or multiple objects. If you select multiple objects, your next 
mouse action or command affects all of the selected objects. For example, if you 
selected two objects, you could cut or copy them as if you had selected a single 
object.

Changing the size and shape of objects 
You can change the size and shape of any object by dragging a sizing handle.

To change the size of an object:
1. Select the object you want to resize.
2. Drag a handle until the object is the size you want.

To select... Do this...
A single object Click the object.
Multiple objects SHIFT+click each object. 
All objects on the page From the Edit menu choose Select All.
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Note: If you want to resize an object proportionally, press CTRL as you drag 
a corner handle. 

Moving objects between layers
When you add a button or another object to a page, ToolBook adds a layer to the front 
of the current page and then places the button on that layer. When objects overlap, 
the objects on higher layers appear to be placed on top of objects on lower layers.

To move an object to a higher or lower layer:
1. If the Book Explorer is not open, from the View menu choose Book Explorer.
2. Select the object you want to move in the Book Explorer window.
3. Drag the selected object up the list or down the list and drop it where you want 

it to be.

ToolBook assigns new layer numbers to all of the objects affected by the 
change. 
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Preparing web pages 
for delivery
ToolBook provides a wizard that steps you through the process of preparing a book for 
use on the Internet. After you respond to the prompts shown in the wizard, ToolBook 
builds the web pages for you.

Two methods for distributing an application over the Internet are available through 
ToolBook. This chapter focuses on the most popular choice: delivering a series of web 
pages.
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Delivering web pages  
ToolBook can export your book as a series of web pages that incorporate DHTML 
automatically. Dynamic HTML, or DHTML, extends HTML by adding the ability to 
create interactive features such as buttons that respond to a click, scrolling text, 
animations and more. In ToolBook, the preprogrammed objects in the catalog have 
these features built in. 

ToolBook builds web pages from your book when you use the Web Specialist.

Using the Web Specialist
You start this process of creating web pages by opening the Web Specialist, a wizard 
that gathers information and exports your book.

Figure 1  ToolBook Web Specialist
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When starting a new book in ToolBook you are prompted to choose the deployment 
method, which is the way you will deliver the book. Choose DHTML as the 
deployment method when you plan to deliver web pages.

To prepare web pages by using the Web Specialist:
1. Open the book you want to export.
2. From the File menu, select Publish to Web (DHTML).
3. Follow the instructions in the ToolBook Web Specialist.

As soon as the export process is finished you can view the web pages in a browser. 
The file named index.html opens the first page in the series of exported web pages. 
You can locate this file in the folder named WebExport by default; it is located in the 
folder where your book is stored. In the WebExport folder, ToolBook creates another 
folder with the same name as your book file. There you will find all the files required to 
run your application on the web. To view your exported web pages, open the file 
named index.html.
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CHAPTER 8
Scoring tests and 
tracking with an LMS
You may include questions as part of a quiz or assessment you create in ToolBook. 
The catalog has question objects that determine what responses individual users 
make. ToolBook calculates the score for answers. 

Assessment results can be stored by a learning management system (LMS). An LMS 
that conforms to the SCORM or AICC standards can track the scores that learners 
earn when taking ToolBook courses.
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Building an assessment
An assessment is a test or quiz with questions to be answered by each person who 
takes the course. You can create an assessment in ToolBook in these ways:

• Add a question object from the catalog to a page.

• Start a book from a quiz template.

• Start a new book with the Book Wizard and choose the Quiz Book option.

The score and answer options for a question are available by opening the extended 
properties for the question as described below. 

To set the correct answer for a question:
1. Select a question object on a page.

2. Click the Extended Properties  button on the toolbar.

3. Click the Answers tab in the Properties for Question dialog box.

4. Each answer choice displays a checked graphic or not correct graphic to the 
left; click this graphic to change the setting.

If you want to display a student's score, use the Show Score or Score this Quiz 
buttons available from the catalog in the Scoring and Tracking category. These 
buttons calculate the score and display the results in a Score Field object, which is 
also available from the catalog.

With most types of question objects you can assign a weight to every answer. You can 
modify the default weights in the Properties for Question dialog box.

Feedback is the way a question object responds when a learner enters an answer. For 
example, a question object can display the word “Correct” in a pop-up box after a 
learner chooses the right answer. For descriptions of the types of feedback you can 
set for an answer, look in the User Guide PDF file available from the Help menu in 
ToolBook.
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Preparing content for an LMS
If you plan to publish pages created in ToolBook through a learning management 
system:

• Include an Exit button on one or more of the pages to allow the score and 
completion information to be sent to the LMS. Exit buttons are located in the 
catalog in the Scoring and Tracking category.

• Prepare the ToolBook course for delivery. From the File menu, choose Publish to 
Web (DHTML). ToolBook creates a single package file that you can publish 
through an LMS.

When you prepare your book for delivery by using the Publish to Web command, 
SCORM or AICC support is added automatically to your book. This allows quiz and 
assessment results to be tracked and stored in an LMS database. ToolBook sends a 
learner's score to the LMS when the learner clicks the Exit button prepared for this 
purpose.

You may use more than one type of Exit button. For instance, you might use an Exit 
(Suspend Lesson) button on most pages to allow the learner to stop after finishing part 
of the course and resume it at a later time. On the final page you could replace the 
button with the Exit (Mark as Complete) button to record the final score and mark the 
course as complete in the LMS.

While you are creating content in ToolBook, you can test it by using the Publish to 
Web command from the File menu. View the exported pages in a web browser to 
make sure they meet expectations. If your LMS provides a testing environment, it’s 
best to launch the content through the LMS and go through each page before 
releasing the content to the intended audience. Verify that the score displays 
appropriately and graphics appear as you intended. Check to see if each link opens 
the correct page. Test the content in all browsers that your audience may use.
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Further information
An online User Guide is available from the Help menu in ToolBook. This book explains 
the interface, tools, menus, and many features of ToolBook. Detailed information is 
also available from online Help. For access to tutorials and other resources, visit 
www.toolbook.com. 
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